Grizzly Riders Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
hi guys,

i've got an 08 700fi grizzly i've owned since new and in the last couple of months whilst riding the engine seems to be missing momentarilly and the reverse light flicks up when this happens. i use the bike for hunting so 95%of its life is spent around the 20km/h mark, the problem doesnt seem as bad/noticiable when going faster 50km/h plus. i've tried new air cleaner and injector cleaner. even put it into the yamaha shop but still the same....

just wondering if anyone else has had this problem?? have searched threads on similar problems but without the reverse light flicking up.

any help would be great.
 

·
DJ
Joined
·
1,299 Posts
hi guys,

i've got an 08 700fi grizzly i've owned since new and in the last couple of months whilst riding the engine seems to be missing momentarilly and the reverse light flicks up when this happens. i use the bike for hunting so 95%of its life is spent around the 20km/h mark, the problem doesnt seem as bad/noticiable when going faster 50km/h plus. i've tried new air cleaner and injector cleaner. even put it into the yamaha shop but still the same....

just wondering if anyone else has had this problem?? have searched threads on similar problems but without the reverse light flicking up.

any help would be great.
You have the classic symptoms of a bad neutral/reverse switch. Replace the switch part # 3G4-82540-01-00 (updated part). About $20 online.This switch sits on top of the middle tranny to the rear of the cylinder. Kinda looks like a spark plug. Also replace the sealing washer that sits under the switch.You can confirm that the switch is the problem by grounding the wire going to the switch. After grounding the engine miss will be gone but reverse light will stay on. This is called the reverse limiter override mod.
 

·
Registered
Joined
·
104 Posts
x2. 100% the reverse switch. replace that and the spark plug. get to it by pulling your right side plastic, as well as the cvt snorkle tube.

simple fix. dont wait till it gets bad, or it will rev limit at 10 or 15mph all the time.

id be pretty pissed at the dealer you took it to. this is a common issue and it should have been a no brainer fix.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
thanks fellas. i'll be ringing the dealers today. Any idea where to get the switch from tried Ebay but no good. wonder what there worth from yamaha???
 

·
Registered
Joined
·
104 Posts
thanks fellas. i'll be ringing the dealers today. Any idea where to get the switch from tried Ebay but no good. wonder what there worth from yamaha???
Partshark dot com usually has the best OEM prices I've found.

Sent from my DROID RAZR HD using Tapatalk 2
 

·
Registered
Joined
·
11 Posts
Ive got an 07 700fi and i had the same problem before its always right around oil changes. Certain oil makes the reverse switch act crazy. Everytime it would do it id take it out and clean it. Wouldnt do it for about an hour or two then start again. I finnaly figured out that if i run cheap oil it doesnt do it. Really dont understand it
 

·
DJ
Joined
·
1,299 Posts
Ive got an 07 700fi and i had the same problem before its always right around oil changes. Certain oil makes the reverse switch act crazy. Everytime it would do it id take it out and clean it. Wouldnt do it for about an hour or two then start again. I finnaly figured out that if i run cheap oil it doesnt do it. Really dont understand it
:BS: ::what:::s_laugh::BS: So how many times have you taken it out and cleaned it????????
 

·
Registered
Joined
·
11 Posts
Shit alot. I tried to run Yamalube and Royal Purple and Castrol Motorcycle Oil. Allof them made it do that. Drained it. Went got the lil $1.99 qrts from the local store and it doesnt happen.
 

·
Registered
Joined
·
104 Posts
shit alot. I tried to run Yamalube and Royal Purple and Castrol Motorcycle Oil. Allof them made it do that. Drained it. Went got the lil $1.99 qrts from the local store and it doesnt happen.
uhh, have you tried something like.. i dunno... changing the reverse switch? cheap oil is most likely has friction modifiers and is burning up your wet clutch.
 

·
Registered
Joined
·
11 Posts
Well if it is it'll be alright. This problem hasn't occured in ab a year. Of course im not running cheap oil now.:chillin:
 

·
DJ
Joined
·
1,299 Posts
Well if it is it'll be alright. This problem hasn't occured in ab a year. Of course im not running cheap oil now.:chillin:
:Shh: So with good oil in it, it should start crapping out again on top end any second now, Right!!! :laugh1:

Just kidding ya man, but the oil thing and the reverse/neutral switch just doesn't make any sense to me. Co-incidence?
 

·
Registered
Joined
·
1 Posts
:Shh: So with good oil in it, it should start crapping out again on top end any second now, Right!!! :laugh1:

Just kidding ya man, but the oil thing and the reverse/neutral switch just doesn't make any sense to me. Co-incidence?
You have the classic symptoms of a bad neutral/reverse switch. Replace the switch part # 3G4-82540-01-00 (updated part). About $20 online.This switch sits on top of the middle tranny to the rear of the cylinder. Kinda looks like a spark plug. Also replace the sealing washer that sits under the switch.You can confirm that the switch is the problem by grounding the wire going to the switch. After grounding the engine miss will be gone but reverse light will stay on. This is called the reverse limiter override mod.
So I got a replacement switch (3GB-82540-01) and it worked for a bit but once again had the same problem. Did I get the wrong part? Its not the same number you posted.
 
1 - 13 of 13 Posts
Top