Grizzly Riders Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Came back on very rough trail at night. First, lights dimmed out; pretty soon engine gave out. Obviously battery not charging and magneto? not producing. Long dark tow back on a not so friendly trail. Maybe I shook a wire loose? Where is the magneto? 2005 660 grizzly
 

·
Mad Fabricator
Joined
·
227 Posts
I would start by looking at the battery and all your wiring. Some batteries don't do well on rough terrain, may have dropped a cell or the wires came loose.

I'd have to look at a parts diagram to see which side the Stator is on (no magneto on these). It will be inside the crankcase, I know 700s its on the left side, possibly the same with the 660s.
 

·
Super Moderator
Joined
·
11 Posts
Came back on very rough trail at night. First, lights dimmed out; pretty soon engine gave out. Obviously battery not charging and magneto? not producing. Long dark tow back on a not so friendly trail. Maybe I shook a wire loose? Where is the magneto? 2005 660 grizzly
Check your battery connections, and then next would be your voltage regulator.
After that, i would check your stator

Sent from my Pixel 5 using Tapatalk
 

·
Registered
Joined
·
4 Posts
Came back on very rough trail at night. First, lights dimmed out; pretty soon engine gave out. Obviously battery not charging and magneto? not producing. Long dark tow back on a not so friendly trail. Maybe I shook a wire loose? Where is the magneto? 2005 660 grizzly
I have set up additional lights that are solar run only and they work great. You can use them for topping of your battery all the time during the day!
 
1 - 7 of 7 Posts
Top